Page MenuHomeWildfire Games

Target 10.9 as minimal OSX version
ClosedPublic

Authored by Itms on Sun, Dec 2, 3:01 PM.

Details

Summary

10.9 is the minimal target we can support, as SpiderMonkey requires it (other libraries give us lower limits).
Please note that some features (like TLS support with gnutls) can be malfunctioning on these older platforms, but the compilation process works and the game runs.

Test Plan

Test the update-workspaces change on another Unix just to be sure.

Diff Detail

Repository
rP 0 A.D. Public Repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

Itms created this revision.Sun, Dec 2, 3:01 PM
Vulcan added a subscriber: Vulcan.Sun, Dec 2, 3:02 PM

Successful build - Chance fights ever on the side of the prudent.

Link to build: https://jenkins.wildfiregames.com/job/differential/809/

Stan added a subscriber: Stan.Sun, Dec 2, 7:44 PM
Stan added inline comments.
build/workspaces/build-osx-bundle.sh
28 ↗(On Diff #7017)

Isn't that incorrect since I can't build on 10.9.5 ?

Unless it's the minimum supported system and not the minimum supported build system

Itms marked 2 inline comments as done.Sun, Dec 2, 8:03 PM
Itms added inline comments.
build/workspaces/build-osx-bundle.sh
28 ↗(On Diff #7017)

It is indeed the minimum supported running system.

This revision was not accepted when it landed; it landed in state Needs Review.Mon, Dec 3, 12:08 PM
This revision was automatically updated to reflect the committed changes.