Page MenuHomeWildfire Games

Unit Motion - remove the m_Moving variable

Authored by wraitii on May 13 2019, 9:48 PM.


Group Reviewers
Restricted Owners Package(Owns No Changed Paths)
rP22354: Unit Motion - remove the m_Moving variable

m_Moving is supposed to tell us whether we are trying to move or not (NB: this is different from moving, which implies our position is changing). It was used by IsMoving(), which should be renamed "HasATarget" or something in a later diff.

The variable is not necessary since having a target is equivalent, and this reduces state, so remove it.

Test Plan


Diff Detail

rP 0 A.D. Public Repository
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

wraitii created this revision.May 13 2019, 9:48 PM

Build failure - The Moirai have given mortals hearts that can endure.

Link to build:

wraitii updated this revision to Diff 8397.Jun 9 2019, 5:25 PM

Rebased for committing.

Vulcan added a comment.Jun 9 2019, 5:30 PM

Successful build - Chance fights ever on the side of the prudent.

Link to build:

This revision was not accepted when it landed; it landed in state Needs Review.Jun 9 2019, 7:04 PM
This revision was automatically updated to reflect the committed changes.