Upload RIP again, well patch easy enough to review without context. I guess arc is complaining about the spaces in the mapfile names, also committer needs to be careful with the file move...
Mon, May 13
looks like all summary percentages have a symbol now
No other cases of "archery" in code
I don't think this patch helps D981 a great deal, since consider a unit that is asked to attack something and unitmotion drops it of (with a moveToRange function) just outside the area an IsInRange function thinks it is in range. With this patch unitAI will now think the unit can't move and thus do nothing, meaning we will get idlers.
Thu, May 2
Thanks for noticing this, didn't we also rename the archery class in the commit?
Sat, Apr 27
comment I had laying around:
Fri, Apr 26
Among other things we should be able to spawn units in autogarnison if free slots but it's not the diff for that)
Careful with Extinct volcano OP-ness (on that map autogarrison would give a significant advantage to some civs)
Wed, Apr 24
Apr 21 2019
k, now I understand the problem, gaelic hardcodes that 1 and 11 must always be the singular form, however that isn't the case in this string.
Patch still applies correctly, reads correct, front doesn't fall => accept
If the value that SetSpeedRatio computes differs from the serialized value, by definition it's OOS?
However, that value can only differ if m_SpeedRatio > std::min(ratio, m_RunSpeedMultiplier).
Which is impossible because the only place modifying m_SpeedRatio is SetSpeedRatio, which does m_SpeedRatio = std::min(ratio, m_RunSpeedMultiplier).
consider modifiying m_RunSpeedMultiplier too, which is only done on ownershipchange and valuemodification (afaik), where we set the value too
when someone decides to have something other than a grain field, one can always change it in the parent.
Host a game and join with another player (both with the patch ofc), load the game and move stuff around (in formation, guard, attack a deer, do a tech etc.), leave with the joiner, and rejoin. Now move some more stuff and wait a little.
UnitMotion cannot know if this speed is on purpose or not so always adjust and let unitAI and such adapt
Assume this comment is true,
then UnitAI changes the runmultiplier and it yields an OOS, correct?
How will UnitAI change the runMultiplier? it is a template value, maybe modified by some tech...
Isn't serialization of the run multiplier so that UnitMotion can know if this speed is on purpose?
Where is it serialized? It is desirialized such that the rejoiner knows that a tech is researched, further it is a template value.
Is the deserialized runmultiplier read from? It looks like it's overwritten with a different value before it's read from.
The only other place I see it is set, is the init, which should be earlier right?
I noticed that some structures have smaller cost than loot, which looks a bit weird. Leaving that as is for now, this patch doesn't change this.
Apr 20 2019
Apr 16 2019
concern fixed by rP20939
Apr 15 2019
Cav got removed from ranges (which makes sense)
Some bot is complaining that this patch is rotting to long and needs a license year update
Renamings of spear => spearman and co is good imo (wasn't there some earlier revision where it was discussed?)
Apr 14 2019
Comments By: elexis, Imarok
proofreading the gamesetup xml and global objects says the patch is complete (did not read the full file for any hidden tooltip in the code)
Thx for the patch
Apr 12 2019
Reading it again, the actual question is how to treat special (the rest looks good)
Changes to trivial to not accept,
Maybe build time, wood cost, and loot ought to be made proportional to health, e.g. health/50?
Whatever makes sense compared to the other palisade structures. e.g cost wise a rocks_curve is pretty similar to a rocks_long, right?
I assume agricultural products would be the most general term? Do we want that in game?
Apr 7 2019
I get that ppl can choose whatever name they want, but who is named 4c905de7e2c9950b7d83273a8070b072 (second one in the german list)? I tried finding him/her in transifex but no luck.
I won't stop anyone for making/commiting a temporal fix, but the underlying problem is that we have two components (buidlingAI and unitAI) on the same unit trying to achieve the same thing (attack something). In the end that is the thing we need to fix (as in subunits)
Apr 6 2019
Calling the traders out of scope of this patch
Checked the difference between the templates as they are loading in game (by printing them out), it resulted in a number of actual changes, giving them below, some of them are not a problem (or actually make sense), a few need to be addressed.
That must be a copy-pasta, text.delete.right doesn't have it, so completeness in that sense
changing vegetables to grain wouldn't work since f.e. the Chinese mod has rise fields instead. One could consider "crops" though.
reads correct, greps complete, unit demo works => accept
Apr 5 2019
As elexis mentioned the color animation would in the vanilla game be dead code, thus that shouldn't be there. Ofcourse it could be useful later, so I would propose to implement the system for the size only, but keep it extendable so the color could easily be added when required.
Mar 18 2019
Grepping says these are all cases of seige, so correct and complete
Mar 17 2019
Reads correct, checked all formation templates => accept
I get that some languages use singular for every other prime number, so to speak. But isn't exactly that the reason why we have markForPluralTranslation, so a translation can choose for which values it takes whatever form. If that isn't the case in the current code, we might have found a bug in our code. Stating the same problem more concretely: how is this particular call different from all the other markForPluralTranslation calls? or are all of them just wrong? (there are some in buildrestriction, wonderVictory, CaptureTheRelic, triggerHelper and Treasure Island)
Code should stand on itself, not referring to a phabricator revision. But isn't markForPluralTranslation designed to cover this case? So how does this solve the issue?
Furthermore markForPlural expects 3 arguments, now it only has 2.
Is that lengthy comment really required? Seems obvious from the code (or it is me who has such a language as mother tongue)
Period complaint while at it
Candidate != must be moved, I guess those should be in the children then...
GarrisonHolder: change the Max attribute in the childs, put the rest in the parent
That is a good point indeed, so we should be looking at which properties we can move to the military parent. Territoy, Vision, GarrsionHolder and Sound seem to be the biggest candidates
Can I propose to make a template_structure_military_training (or find better name) template as a parent of barracks, stable and range? That would solve the duplication of this patch and D1790
Patch reads correct, unit demo test succeeded, grep gives translate hate=> accept
Mar 16 2019
Idea is ok, but patch is inclomplete: your grep doesn't seem to have found the skirmish buildings (the templates under skirmish/structures/)
Indeed inconsistent and misleading naming. Patch correct and complete, front doens't fall, also not in atlas