- User Since
- Apr 17 2017, 9:58 PM (196 w, 1 d)
Sun, Jan 17
This proposal is old, I now have a little easier to describe the "issue" (which is not really one) .
Dec 4 2019
fix linter warning
Dec 3 2019
Dec 2 2019
Dec 1 2019
Nov 29 2019
I am against the use of the word time, at least alone.
rate is used mainly to talk about money or a pourcentage.
Here we are talking about a movement so the use of the word speed is more appropriate.
Nov 22 2019
Nov 7 2019
Can you document the use of timeParameter somewhere?
Nov 3 2019
Nov 2 2019
It is possible to simplify this into only 1 function than to use 2 functions to start and stop the timer.
I also wonder if it is necessary to cache the template values.
This is not the best way to go. It is preferable of change the current model/implentation than to do this.
#5387 as a reference of OOP pattern usage as said @elexis.
#3806 can take account to @bb attached patch / #5322 for gamesetup rewrite.
Yes that is, add the ability. At the moment I do not have the impression that there are auras or technologies that modify this value.
It would be necessary too to take into account that the value of interval time can change and modify the timer in this case.
It's true Capture is considered as an attack in templates but to express the capture we do not use the Attack word.
I think in the case of a capture it is necessary to specify like:
Soldiers and Siege Engines +25% attack rate, +25% capture rate.
I wonder if it is necessary to indicate the types of attack here.
The sentence could be shorter.
Oct 29 2019
Since this revision the dataCounter object is not hidden when there is not counter.
Oct 25 2019
Is it possible to include in art-related commits, images or gif?
It would give more visibility on the work of the artists.
Oct 22 2019
Very detailed demonstration.
Oct 20 2019
Sep 17 2019
It looks good to me.
All calls to this function with unused arguments have been removed.
Jun 19 2019
Jun 5 2019
Just create an object literal.
Why not just use Singleton pattern instead using prototypes if only one instance?
Jun 1 2019
You can remove descriptions if they are not really descriptive and used for the moment .
Maybe change the name of GetTypes() -> GetCodes() to reflect what it really returns and to be consistent with resources.
You can remove some return true.
May 31 2019
For the translation, you need to focus only in the GUI part.
Look specially to common/tooltips.js
May 25 2019
resources parameter in GetTemplateDataHelper() became unused in the function.
May 20 2019
Test is better than words.
The problem with the current code is that at no time we recover the real size of the backgrounds.
Depending on the window size the tiling backgrounds are more or less fully displayed.
For the rounding I thought about ceil rounding timeRemaining in GetQueue().
But I don't know if it's the best thing to do or the best place.
You forgot to put the full context to the diff.
var -> let
May 19 2019
- Moves MAX_QUEUE_SIZE into the prototype.
- Integrates the lateness parameter from Timers.
- Also fix errors forgotten according to the comments.
May 18 2019
The timers can have lateness, should not we include this?
May 12 2019
Tested and its works as expected in relation to the ticket.
Move the decrementation entity limit only when the entity has been successfully spawned and before the ownership attribution seems correct.
May 6 2019
You are right but it's not easier and usual to use length form to iterate in an array?
this.mirages is an array.
Apr 27 2019
Better to separate this into several differentials and with real things to cleanup.
Refactor RemoveBatch function.
Then correct the length check entityCache.
Apr 25 2019
So it was intended. :d
Apr 24 2019
It should be determined if we want certain elements of the background can't be stretched.
But it can also cause this sprite could be too small compared to other elements for wide screens.
Use a hack instead of JS modifications.
The JS changes were almost the same as the code for tilling.
Apr 22 2019
The Icons of units concerned are no longer displayed.
You forgot to include the renaming pictures with the new names.
Eg: hele_mechanical_siege_lithobolos_packed.png -> hele_siege_lithobolos_packed.png
Mar 8 2019
You could use "Update Diff" in right panel or update via arch.
Feb 16 2019
He means the context lines (lines before and after the codes that are modified).
For each patch, you must add the full context.
To add these lines, refer here.
Feb 7 2019
One ticket about this. #3800
What do you mean by the sprite's attribute?
Feb 6 2019
Disables the notification by default.
Change user to client in option's description.
Feb 5 2019
You are right. I will change that.
Jan 31 2019
Upload the sound.
New update with a new dedicated Bell tree sound.
Thank's to @Samulis for the creation.
Jan 25 2019
Maybe try rather adapts the code with the fonction enunciate by smiley.
Jan 24 2019
Maybe a better balcony scale.
And remove the effect.
- Rephrase in options.
- Changes according to Imarok comments. (don't hide all messages of currents players)
I didn't really notice the clouds move too fast but maybe its just me.
Jan 18 2019
Oct 18 2018
Oct 17 2018
Apr 22 2018
Dec 20 2017
Nov 17 2017
The number of games can be split above the GamePanel imo.
I think it can be useful when a multiplayer game starts after the countdown.
But this is probably the only way this function can appear.
Idk if the new globals.js file is needed, there isn't another file where this function can be placed?
Oct 25 2017
Oct 13 2017
This countdown can be useful also if added with a countdown sound.
2 differents sounds:
- during the countdown
- and when the game start really.
If the idea is to find the game where the player was playing, i think it would be better to display a pop-up to reconnect to the game when the player is in the lobby.