Page MenuHomeWildfire Games

Vantha ( )
User

Projects

User Details

User Since
Mar 30 2024, 10:25 PM (10 w, 5 d)

Recent Activity

Wed, Jun 12

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Is there anything else left to change?

Wed, Jun 12, 11:28 PM
Vantha added inline comments to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Wed, Jun 12, 9:47 PM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Wed, Jun 12, 9:46 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

I added D5278 as a parent and will update this diff as soon as that is committed.

Wed, Jun 12, 12:09 PM
Vantha added a comment to D5278: Rename the "color" property of olist columns to "textcolor" .

After its commit https://trac.wildfiregames.com/wiki/PortA26ToA27 should be updated accordingly.

Sure, I can do that.

Wed, Jun 12, 12:06 PM

Mon, Jun 10

Vantha added a comment to D5278: Rename the "color" property of olist columns to "textcolor" .

Sorry for the late reply.
I just succesfully tested it. These should now be all files that need to be changed. As far as I can tell it's complete.

Mon, Jun 10, 10:50 AM
Vantha updated the diff for D5278: Rename the "color" property of olist columns to "textcolor" .
Mon, Jun 10, 10:46 AM

Mon, Jun 3

Stan awarded D5278: Rename the "color" property of olist columns to "textcolor" a Like token.
Mon, Jun 3, 5:10 PM
Vantha requested review of D5278: Rename the "color" property of olist columns to "textcolor" .
Mon, Jun 3, 12:13 PM

Sun, Jun 2

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
In D5269#224957, @Stan wrote:

I wonder how many files are affected.

Not that many. From a quick count, there are around 10 files with olists in the game whose column's property would have to be changed, plus around 3 files implementing the feature.

Sun, Jun 2, 7:48 PM

Sat, Jun 1

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Ok. How about I leave it at "colorSelected" for now and then open a new diff to rename "color" to "textcolor" and "colorSelected" to "textcolor_selected"?

Sat, Jun 1, 11:17 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Does the font color of columns have to named color though? For all other GUI elements it is textcolor. What about renaming it to this? We could then also use the name textcolor_selected.

Sat, Jun 1, 5:33 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
In D5269#224895, @Stan wrote:

color is the standard css name for font color.

Ok, that makes sense.
But I don't quite understand what you're getting at...

Sat, Jun 1, 2:25 PM

Fri, May 31

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

The textcolor attribute of columns is just called "color", so I figured its selected variant should be called "colorSelected"

Fri, May 31, 11:13 AM

Thu, May 30

Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Ok, I changed it accordingly.

Thu, May 30, 12:13 AM

Wed, May 29

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Sorry for not writing earlier.

In this patch i wouldn't change *::Draw at all. And i wouldn't change the signature of *::DrawList.

@phosit Why not? Wouldn't that be the most logical solution?

When you change the signature you have to change other files like CDropDown.
Also i'm shy of changing signatures in class hirarchies. When you forget to change something, it might silently select the function from the parrent.

So you are recommending to not pass m_TextColorSelected to DrawList and instead read it directly? Isn't this way a bit inconsistent when compared to the handling of all other properties?

Wed, May 29, 7:53 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

In this patch i wouldn't change *::Draw at all. And i wouldn't change the signature of *::DrawList.

@phosit Why not? Wouldn't that be the most logical solution?

Wed, May 29, 11:06 AM

Sat, May 25

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

What is the best solution?

In this patch i wouldn't change *::Draw at all. And i wouldn't change the signature of *::DrawList.

Are you sure? That would mean accessing m_TextColorSelected directly but all other properties (including m_TextColor) through parameters of the function.

We don't need both the functions COList:Draw() and COList:DrawOList, we can merge them into one overriding CList:Draw().

We can do that in a future diff.

I mean, it's not unrelated to this diff. It's already editing COList::Draw(O)List anyway.

Sat, May 25, 7:10 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

As far as I'm understand, the code calls the Draw() function first for each GUI object. CList::Draw() then calls CList::DrawList().

Does CList::Draw() _only_ call CList::DrawList(). Yes it does (weird/useless function).

I think the awkward calls and overrides of the two functions Draw() and DrawList() are done, so the dropdown can execute code before drawing the list.

Sat, May 25, 2:34 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
In D5269#224735, @Stan wrote:

@phosit any reason we're casting to unsigned int rather than size_t?

No it's better to cast to size_t.

Ok, I changed that.

Code which previously called COList::DrawList doesn't find that anymore and calls CList::DrawList instead. Which is wrong i think.

As far as I'm understand, the code calls the Draw() function first for each GUI object. CList::Draw() then calls CList::DrawList(). COList previously ìnherited Draw()and only overrode DrawList(). But now with the extra property textColorSelected that OList doesn't need, we can remove that parameter from its drawing function. I therefore made COList also override Draw() to now call the new function COList:DrawOList() instead, with parameter less than previously CList:DrawList().

Sat, May 25, 11:39 AM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Sat, May 25, 11:39 AM

Fri, May 24

Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Fri, May 24, 6:55 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

removed the extra parameter textColorSelected from COList::DrawList()

You didn't do that. Right?

I did. See COList.cpp line 305 and COList.h line 76.

Fri, May 24, 6:47 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Ok, I wrote the page (https://trac.wildfiregames.com/wiki/GUI_-_OList) and also added the missing properties here: https://trac.wildfiregames.com/wiki/GUI_-_Properties and the reference here:https://trac.wildfiregames.com/wiki/GUI_-_Scripting_Reference

Fri, May 24, 5:09 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
In D5269#224721, @Stan wrote:

Most of the GUI pages are outdated so it's very possible the page may be not created. Do you want me to create one so you can edit it?

Fri, May 24, 1:51 PM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Is the code fine as it is or does something else need to be changed?

Fri, May 24, 10:51 AM

Tue, May 21

Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Tue, May 21, 7:10 PM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Tue, May 21, 6:02 PM
Vantha added inline comments to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Tue, May 21, 6:00 PM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.

removed the extra parameter textColorSelected from COList::DrawList()

Tue, May 21, 5:56 PM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.

This should prevent the compiler warnings.

Tue, May 21, 2:17 PM

Mon, May 20

Vantha added inline comments to D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Mon, May 20, 9:36 PM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.

updated the copyright years

Mon, May 20, 9:36 PM

Sun, May 19

Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Ok. I removed the whitespace.

Sun, May 19, 11:49 AM
Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Sun, May 19, 10:56 AM
Vantha added a comment to D5269: Finish implementing property "textcolor_selected" for list GUI objects.

Thanks.
Are the problematic whitespaces still there? I couldn't find them in the files, but the inline comment is gone now.

Sun, May 19, 12:14 AM

Sat, May 18

Vantha updated the diff for D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Sat, May 18, 11:59 PM
Vantha requested review of D5269: Finish implementing property "textcolor_selected" for list GUI objects.
Sat, May 18, 12:01 AM

May 9 2024

Vantha added a comment to D5256: Remove Roman numerals from bot names.

Nice. Is there anything else you want me to change?

May 9 2024, 4:17 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
May 9 2024, 4:16 PM
Vantha added inline comments to D5256: Remove Roman numerals from bot names.
May 9 2024, 11:14 AM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
May 9 2024, 11:10 AM

May 8 2024

Vantha added inline comments to D5256: Remove Roman numerals from bot names.
May 8 2024, 11:14 PM
Vantha added inline comments to D5256: Remove Roman numerals from bot names.
May 8 2024, 2:24 PM

May 7 2024

Vantha added inline comments to D5256: Remove Roman numerals from bot names.
May 7 2024, 6:52 PM
Vantha added a comment to D5256: Remove Roman numerals from bot names.
May 7 2024, 6:48 PM
Vantha added a comment to D5256: Remove Roman numerals from bot names.

elexis said that this revision should not be marked as closing ticket #3307 because it doesn't resolve all of that ticket. So, remove the reference to ticket #3307 in the ticket field. Then add a comment to the description stating that this resolves part of ticket #3307.

May 7 2024, 1:49 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
May 7 2024, 1:45 PM

Apr 28 2024

Vantha updated the diff for D5256: Remove Roman numerals from bot names.
Apr 28 2024, 8:14 PM

Apr 26 2024

Vantha added inline comments to D5256: Remove Roman numerals from bot names.
Apr 26 2024, 9:16 AM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
Apr 26 2024, 9:16 AM

Apr 24 2024

Vantha added inline comments to D5256: Remove Roman numerals from bot names.
Apr 24 2024, 9:14 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.

I addressed most of the suggestions.

Apr 24 2024, 9:13 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.

Ok, updated the diff. Is this how you wanted the comments?

Apr 24 2024, 3:29 PM

Apr 23 2024

Vantha updated the diff for D5256: Remove Roman numerals from bot names.

Like this?

Apr 23 2024, 8:30 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.

I added/updated the comments. Do you also want a comment before line 95? This.CountLabel is already marked for translation at this point (and has a comment explaining what it is).

Apr 23 2024, 12:20 PM

Apr 21 2024

Vantha updated the diff for D5256: Remove Roman numerals from bot names.

Ok, nice. Made the change and added the trac ticket.

Apr 21 2024, 12:11 AM

Apr 20 2024

Vantha added inline comments to D5256: Remove Roman numerals from bot names.
Apr 20 2024, 12:02 AM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.

Ok, I made the change.

Apr 20 2024, 12:01 AM

Apr 19 2024

Vantha added a comment to D5256: Remove Roman numerals from bot names.

OK, and what's preferred?

Apr 19 2024, 5:34 PM

Apr 18 2024

Vantha added a comment to D5256: Remove Roman numerals from bot names.

Before this diff the "forat translation" is allways done. That's almost certainly an issue.

Not sure what you mean by this, though. What should I change?

Apr 18 2024, 6:51 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
Apr 18 2024, 6:49 PM
Vantha added a comment to D5256: Remove Roman numerals from bot names.

I don't like it when data is mutated. (With the +=)
If one wants to know what's in the variable one has to reason about every point where it get's mutated.
If it's const one only has to reason abot the initialization.
Ideally there should be a chosenName and a translatedChosenName:

const translatedChosenName = this.settings.isNetworked ? chosenName : translate(chosenName);

elexis just wrote me again :)
User visible strings shouldn't be concatinated by + (or +=).

Apr 18 2024, 3:01 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
Apr 18 2024, 2:38 PM

Apr 17 2024

Vantha added inline comments to D5256: Remove Roman numerals from bot names.
Apr 17 2024, 8:22 PM
Vantha added a comment to D5256: Remove Roman numerals from bot names.

I never saw Template Literals in this codepase. I don't object it. :)

Apr 17 2024, 8:19 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.
Apr 17 2024, 8:03 PM

Apr 8 2024

Vantha updated the diff for D5256: Remove Roman numerals from bot names.

The Mauryan emperors were sorted chronologically. I put them in alphabetical order too.

Apr 8 2024, 6:22 PM
Vantha added a comment to D5256: Remove Roman numerals from bot names.

When the AINames are empty or don't exist, the game already throws errors before the step of choosing the names.

Apr 8 2024, 1:37 PM
Vantha updated the diff for D5256: Remove Roman numerals from bot names.

changing three let to const

Apr 8 2024, 1:30 PM

Apr 7 2024

Vantha requested review of D5256: Remove Roman numerals from bot names.
Apr 7 2024, 3:29 PM