- User Since
- Jan 6 2017, 3:41 PM (110 w, 5 d)
- Fix space after xml tag
- Add limit
- Fix missing changes after cleanup
- Make delay not optional
- Exclude 0 from interval
- Use changeKey instead of key.
Mon, Feb 18
Not your fault. I just wanted that feature really bad for the players and I did not expect having to spend more than 100 hours on it :/
Okay I'll add both then and make this a monster patch with 6 features in one. I'll also need to rewrite every single resource supply in the game. Sounds great. Gonna take some time though. Good thing we have inheritance.
Is it okay if it's threshold for both ? Can be a threshold below and above right ?
Sun, Feb 17
It's still using the 2017 toolset so yes.
I can't test on VS2013 but the goal is to drop support eventually and move on to 2015 2017 and maybe 2019
Errors for debug build are here https://trac.wildfiregames.com/ticket/4460
To reproduce just start a game in debug mode.
Updating Fcollada is not that important. Nevertheless though our debug build is broken on windows because of it and the game doesn't work with Fcollada compiled with vs2015 instant default.
Sat, Feb 16
Fri, Feb 8
You need to add more classes. And you can't mix stuff. Dunno if it's good
I guess that's somehow meaning that we should check design documents before deleting stuff.
So first of all it's currently
- Update description
- Add infinite check
- rename functions
- Simplify timer call to only pass the key.
@elexis Anything preventing you to commit this ?
- Fix Vulkan warning
- @returns -> @return
Thu, Feb 7
@nani Feel free to suggest values.
- Make the message filter a bit smarter
Perhaps Constraint -> HealthConstraint or HealthCondition.
- Add option to change the interval and restart the timers
- Fix the incorrect description
- Remove parameter from AddRegenTimer function.
- Remove whitespace.
@elexis Okay no problem remove the files.
Sure could add a change
MaxAmount is the max amount of resource an entity can carry.
So MaxAmount is always larger than Amount? And what happens if MaxAmount is not specified?
Should be. In that case Max Amount is set to current amount.
Rate is not changeable by tech/aura. Any reason to change it over the Value ?
Actually I think both ought to be possible. E.g. heal_rate.json technology decreases Heal/Rate, not Heal/HP; for growth having smaller steps could make sense.
Okay but that will need way more code. Because you have to cancel timers for the rate to change I believe.
Wed, Feb 6
How is ResourceSupply/Fattening/Value different ?
Still sounds like a nice change.
- RegenBonus -> Change
- Amount -> Value
- Add Slash in aura name
- Add fish to the list of regenerating templates
- Fix duplication
- Use Growth Spawning and Fattening as tag names for consistency.
- Add more examples and an aura for the corral
- 60 is too much though.
- 1 per 2 seconds for bushes and trees make them infinite for level 3 units.
- @bb Can you tell me if that aura also affects gaia units or just mine ?
Tue, Feb 5
use this.infinite and not the function.
- Remove useless code. (Now that timers are not removed, no need to add them back).
Mon, Feb 4
About serialisation one could just override the serialise function and only serialise specific attributes. It's done like that in other components.
- Use this.amount instead of a function call
- rename corpse to entCorpse
- rename cmpCorpseResourceSupply to cmpResourceSupplyCorpse
- Fix typo copy pasta buildingai
- Simplify condition on destructor.
- Fix coma space typo.
- Add 4 spaces to the conditions.
- Remove tree dead from the list of changed files.
Sun, Feb 3
- Remove whitespaces
- Add a destructor function to clean the timers.
@elexis, Ah Indeed, do we have a destructor function ?
Can rename RegenBonus to Change without issues. Not sure it's the best term for the job but it reads good enough.
- fix condition indent
- remove unneeded parenthesis
- move health disable higher.
- remove complex key name.
- remove the cancellation of the timers.
- move the timers to their own object not initialized if it's not needed.
- add a configurable delay before an object starts decaying or growing.
- rename rate to amount
- remove the subscription to messages as it would not be used anyway.
However it seems hard to have auras/techs affect specific ResourceSupply bonuses. So that might be one reason to go with different names i.e
Sat, Feb 2
Cool ! I'll try to add a set.
If you have one that is both you lose a few lines :)
@elexis I will definitely try to save some memory for trees and only create the array if there is a Regen bonus.
- Fix indent.
- Remove duplication and made code more generic although, way more complex.
I unified it all locally but that makes the code very complex and ugly. Will upload a new version when I figure that one or more bullshirt.
Fri, Feb 1
Yeah duplication annoys me too. The thing is I really need to be able to have too cumulative auras for Regen and Decay and I can't do that with a block with a generic name...
Try to fix Vulkan's comments.
Thu, Jan 31
Can you upload the binary ? Phab will not allow one to download them from a diff. In the comment toolbar use the little cloud with an arrow.
Needs a rebase after D1770
Wed, Jan 30
Remove duplication fix some comments. Thanks @elexis for putting up with me as I am high maintenace, I'm really doing my best to get this right.
Tue, Jan 29
So basically does
I guess it's there not to keep marking the unit as injured every time you get through this. Dunno what's the performance impact, but maybe it's negligible. One could also check for the RangeManager entity flag each time, but that's more lines.
Change var to let.
- Do not serialize GrowsWhenAliveOnly, DecaysWhenDeadOnly.
- Use the function isInfinite() instead of using the field.
- Fix Typo
- Remove the .0 from the diminishing return function.
- Allow techs/auras to change the rate of decaying growing of the units.
- Could be used for instance to boost the animal growing rate near corrals.
- Could be used to reduce the decay of said animals if there are units nearby, or if the area is snowy and has a specific template that does so.
- if( → if ( (This is usually done by VisualStudio, but not me...)
- Do not initialize variables directly, only if Growth and Decay exists Maybe that will help with serialization
- Call UpdateSupplyStatus() from set amount directly
- Fix regenerateTimer variable that shouldn't exist.