- User Since
- Feb 3 2017, 10:51 PM (148 w, 16 h)
Wed, Nov 27
Tue, Nov 26
Mon, Nov 25
Sun, Nov 24
Tue, Nov 12
Fixes some @elexis notes.
Mon, Nov 11
Moves BuildingSnapping to other class.
Sun, Nov 10
Fixes @elexis`s notes.
Sat, Nov 9
Added C++ function to get edges.
Oct 6 2019
Fixes @Stan `s notes.
Adds if ( space and moves destructor to header.
Oct 5 2019
Removes unused variables.
Fixes @elexis `s notes.
Oct 4 2019
Reverts vector changes.
Fixes @elexis `s note.
Oct 3 2019
Fixes @elexis`s notes.
Yeah, I can call it TODO, because I want to remove it after new projection type will be added.
Wrong commit message, the right one is "Fixed assert fails in Actor Editor".
@shh thank you for the patch! Sorry for long reviewing.
My result on macOS (clang-11.0.0) for https://code.wildfiregames.com/P184 (output doubles are in microseconds):
Oct 2 2019
The patch seems ok to me. I'm going to commit that if nobody has objections.
I tested it on VS2015, it works for me. The movement looks ok, the old code has some issues, but it'd be better to fix them in a separate diff.
I didn't talk about underscores, only about name semantic.
I refer to this line: "Then, try to match the style of the other code in the subdirectory you're editing.".
Before your change there were 100 folders with lower case name underscore and 2 with upper case in whole repo excluding third_party and tools. After your change there are 99 folders with lower case name underscore and 6 with upper case
See my comment above. And it doesn't look consistent, because it has tests folder.
Well, before the change we didn't have such name in the folders, but we have tests and scripting. So you broke the rules from CC.
Well its not like I didnt mentioned the folder names or the reasoning several times in the discussion we had http://irclogs.wildfiregames.com/2019-10/2019-10-01-QuakeNet-%230ad-dev.log20:02 < Vladislav> I agree with most, I just can't call it object_base.
It was in context of your patch https://code.wildfiregames.com/P183, and it contains only underscores.
I think Scripting has a wrong case, it's out of repo CC. Object* and SettingTypes are not so "out of rules", but I'd prefer underscore to fit into all other folder names.
I agree that the code should be refactored, but at the same time I want to keep the diff as small as possible (only movement).
Oct 1 2019
Sep 26 2019
Also the code doesn't support square maps.