Page MenuHomeWildfire Games

UnitMotion - improve the name of a function and move stateful effects at the caller.
ClosedPublic

Authored by wraitii on Mon, May 13, 9:05 PM.

Details

Reviewers
None
Group Reviewers
Restricted Owners Package(Owns No Changed Paths)
Commits
rP22299: ShouldConsiderOurselvesAtDestination renamed to…
Summary

It improves readability of the code when a function that seems like it does a simple check actually only does a simple check and the caller is the one changing state.

I think I could actually make it const now, need to check.

Test Plan

Look at the code.

Diff Detail

Repository
rP 0 A.D. Public Repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

wraitii created this revision.Mon, May 13, 9:05 PM

Successful build - Chance fights ever on the side of the prudent.

Link to build: https://jenkins.wildfiregames.com/job/differential/1395/display/redirect

wraitii updated this revision to Diff 8068.Sun, May 19, 4:38 PM

Updated

Successful build - Chance fights ever on the side of the prudent.

Link to build: https://jenkins.wildfiregames.com/job/differential/1444/display/redirect

This revision was not accepted when it landed; it landed in state Needs Review.Sat, May 25, 3:23 PM
This revision was automatically updated to reflect the committed changes.